USB reset script

Minden ami MikroTik szkript!
Avatar
antennatechnika
Hozzászólások: 6
Csatlakozott: 2018. február 11., vasárnap 11:13

USB reset script

HozzászólásSzerző: antennatechnika » 2020. április 6., hétfő 22:34

Sziasztok
A gondom, hogy időként megáll az SXT LTE egységem. Ezt egy scriptel szeretném megoldani, ami a WAN elvesztésekor újraindítja az USB interface tápját és bejegyzést ír a log-ba.
A gondom hogy amit összeratam az csak részben működik, egészében nem, és nem találom a hibát erre kérek segítséget.
A script a scheduler segítségével 2 percenként lefut és ha nincs WAN 6 percre lekapcsolja az LTE tápot :

# USB_reset_script

:if ( [/ping 8.8.8.8 count=10 size=64 interval=120s ] =0)
do={
:log error "-----No ping";
/system routerboard usb power-reset duration=360;
:log error "----Reset USB Power";
} else={
#:log info "-----LTE OK-----";
}
Ha valaki rávilágítana a megoldásra megköszönném.

Avatar
animal
Hozzászólások: 429
Csatlakozott: 2013. február 13., szerda 14:55
Telefonos Elérhetőség: +36305614147
Tartózkodási hely: Budapest
Kapcsolat:

Re: USB reset script

HozzászólásSzerző: animal » 2020. április 7., kedd 12:45

antennatechnika írta:A gondom hogy amit összeratam az csak részben működik, egészében nem


melyik része nem működik? Így azért nehéz segíteni :D

amúgy, ha nyitsz egy terminált és
/system script run SCRIPTED_NEVE
akkor kiírja mi a baja, ha valamit elírtál.

A másik, hogy pinget egyszer kell csak futtatni, a scheduler dolga a többi, count=1 intervall nem kell.....

Kód: Egész kijelölése

:if ( [/ping 8.8.7.8 count=1] = 0) do={
:log error "-----No ping";
} else={
:log info "-----LTE OK-----";
}
Animal - Y9 - Accesspoint - Mikrotik Certificated
- Lehetetlen nincs, csak nehezen kivitelezhető -

Avatar
antennatechnika
Hozzászólások: 6
Csatlakozott: 2018. február 11., vasárnap 11:13

Re: USB reset script

HozzászólásSzerző: antennatechnika » 2020. április 7., kedd 22:30

animal írta:
antennatechnika írta:A gondom hogy amit összeratam az csak részben működik, egészében nem


melyik része nem működik? Így azért nehéz segíteni :D

amúgy, ha nyitsz egy terminált és
/system script run SCRIPTED_NEVE
akkor kiírja mi a baja, ha valamit elírtál.

Köszi az infót ezeket nem ismertem és utalást sem találtam rá.
Egyébként a "részben" alatt azt értettem , ha lefuttatom csak a restart rutint az megy. Ha már beraktam a log rutinokat, annak a bejegyzéseit már nem láttam.
Sajnos ennél az eszköznél időszakos hiba van és ezt akarom a diskre menteni hátha rájövök a problámára. Sokszor lefagy ás távolról sem érem el. Próbálnám újraindítani az LTE részt h leszakadjon a kapcsolat ha nincs net. De idág még nem jutottam el.
Mégegyszer köszi

Avatar
animal
Hozzászólások: 429
Csatlakozott: 2013. február 13., szerda 14:55
Telefonos Elérhetőség: +36305614147
Tartózkodási hely: Budapest
Kapcsolat:

Re: USB reset script

HozzászólásSzerző: animal » 2020. április 7., kedd 22:53

így működnie kell, szívesen

antennatechnika írta:
animal írta:
antennatechnika írta:A gondom hogy amit összeratam az csak részben működik, egészében nem


melyik része nem működik? Így azért nehéz segíteni :D

amúgy, ha nyitsz egy terminált és
/system script run SCRIPTED_NEVE
akkor kiírja mi a baja, ha valamit elírtál.

Köszi az infót ezeket nem ismertem és utalást sem találtam rá.
Egyébként a "részben" alatt azt értettem , ha lefuttatom csak a restart rutint az megy. Ha már beraktam a log rutinokat, annak a bejegyzéseit már nem láttam.
Sajnos ennél az eszköznél időszakos hiba van és ezt akarom a diskre menteni hátha rájövök a problámára. Sokszor lefagy ás távolról sem érem el. Próbálnám újraindítani az LTE részt h leszakadjon a kapcsolat ha nincs net. De idág még nem jutottam el.
Mégegyszer köszi
Animal - Y9 - Accesspoint - Mikrotik Certificated
- Lehetetlen nincs, csak nehezen kivitelezhető -

Avatar
antennatechnika
Hozzászólások: 6
Csatlakozott: 2018. február 11., vasárnap 11:13

Re: USB reset script

HozzászólásSzerző: antennatechnika » 2020. április 7., kedd 23:23

Szia "animal"
Összehasonlítottam amit írtál az enyémmel és szintaktikai hiba volt a soraimban . Space-k hiányoztak , amint javítottam elindult a script.
Köszi

Avatar
animal
Hozzászólások: 429
Csatlakozott: 2013. február 13., szerda 14:55
Telefonos Elérhetőség: +36305614147
Tartózkodási hely: Budapest
Kapcsolat:

Re: USB reset script

HozzászólásSzerző: animal » 2020. szeptember 1., kedd 19:00

antennatechnika írta:Szia "animal"
Összehasonlítottam amit írtál az enyémmel és szintaktikai hiba volt a soraimban . Space-k hiányoztak , amint javítottam elindult a script.
Köszi


Szia! Örülök ;)
Animal - Y9 - Accesspoint - Mikrotik Certificated
- Lehetetlen nincs, csak nehezen kivitelezhető -


Vissza: “RouterOS közösségi támogatás [ Szkriptek ]”

Ki van itt

Jelenlévő fórumozók: nincs regisztrált felhasználó valamint 1 vendég